觅风易语言学院 PHP学习 定期清理不活跃会员公告 绑定QQ
导读
易语言5.6完美版,可静态编译,绿色无后门

学习易语言 讲究的是系统,如果你正在四处闲逛,你懂的永远是皮毛! 觅风论坛正在为每个困惑的对易语言 详细

[源码] 觅风第20课成绩统计{源码}

[复制链接]

微信扫一扫 分享朋友圈

湮灭 发表于 2018-6-7 19:05:05 | 显示全部楼层 |阅读模式 打印 上一主题 下一主题

马上注册,结交更多易友,享用更多功能,让你轻松玩转觅风论坛。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 成绩, 整数型, , "10"
.程序集变量 下标, 整数型
.程序集变量 a, 整数型

.子程序 _按钮1_被单击

下标 = 下标 + 1
.如果 (下标 > 10)
    信息框 (“已经录入完成”, 0, , )
    平均成绩输出框.内容 = 到文本 (到数值 (总成绩输出框.内容) ÷ 10)
.否则
    成绩 [下标] = 到数值 (成绩输入编辑框.内容)  ' 把“成绩”赋值
    列表编辑框.加入文本 (到文本 (下标) + “:” + 成绩输入编辑框.内容 + #换行符)
    a = 到数值 (总成绩输出框.内容)
    总成绩输出框.内容 = 到文本 (a + 到数值 (成绩输入编辑框.内容))

.如果结束


游客,如果您要查看本帖隐藏内容请回复
1.png
回复

使用道具 举报

精彩评论61

asd26297 发表于 2018-6-7 19:33:11 | 显示全部楼层
谢谢楼主的辛苦分享
回复 支持 反对

使用道具 举报

pei002 发表于 2018-6-7 20:01:18 | 显示全部楼层
学习了,这就去试试
回复 支持 反对

使用道具 举报

啊啊啊啊啊 发表于 2018-6-7 20:29:24 | 显示全部楼层
顶一个了
回复 支持 反对

使用道具 举报

我爱你苏根 发表于 2018-6-7 20:57:31 | 显示全部楼层
支持!!!!前排!!!!
回复 支持 反对

使用道具 举报

我爱你苏根 发表于 2018-6-7 21:25:37 | 显示全部楼层
感觉不错
回复 支持 反对

使用道具 举报

476572199 发表于 2018-6-7 21:29:20 | 显示全部楼层
嘻嘻不错支持一个
回复 支持 反对

使用道具 举报

wangye263 发表于 2018-6-7 21:33:03 | 显示全部楼层
期待中......
回复 支持 反对

使用道具 举报

任逍遥 发表于 2018-6-7 21:36:46 | 显示全部楼层
路过还不错
回复 支持 反对

使用道具 举报

wangye263 发表于 2018-6-7 21:40:29 | 显示全部楼层
赞一个!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注我们:觅风论坛与你快乐分享

官方QQ

服务客服QQ:

466-352-670

客服QQ:466352670

Email:466352670@qq.com

Powered by WWW.EYYBA.COM X3.4© 2001-2013 Inc.   版权所有   

觅风论坛  沪ICP备15020893号-1