觅风易语言学院 PHP学习 定期清理不活跃会员公告 绑定QQ
导读
易语言5.6完美版,可静态编译,绿色无后门

学习易语言 讲究的是系统,如果你正在四处闲逛,你懂的永远是皮毛! 觅风论坛正在为每个困惑的对易语言 详细

[源码] 觅风第19课托盘图标和图片资源另类用法{源码}

[复制链接]

微信扫一扫 分享朋友圈

湮灭 发表于 2018-6-7 12:04:57 | 显示全部楼层 |阅读模式 打印 上一主题 下一主题

马上注册,结交更多易友,享用更多功能,让你轻松玩转觅风论坛。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

置托盘图标 (#图片1, “这是一个托盘图标”)
_启动窗口.左边 = 取屏幕宽度 () - 100  ' _启动窗口. 可不写

.子程序 __启动窗口_鼠标右键被放开, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

弹出菜单 (菜单, , )


.子程序 __启动窗口_被双击, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

载入 (窗口1, , 假)

.子程序 _打开程序_被选择

载入 (窗口1, , 假)

.子程序 _关闭程序_被选择

.如果 (是否已创建 (窗口1) = 真)
    窗口1.销毁 ()
    _启动窗口.销毁 ()  ' 可行,顺序执行
.否则
    _启动窗口.销毁 ()  ' 不可行,走此步,逆行
.如果结束


.子程序 __启动窗口_托盘事件
.参数 操作类型, 整数型

.判断开始 (操作类型 = 2)
    载入 (窗口1, , 假)
.判断 (操作类型 = 3)
    弹出托盘菜单 (菜单)
.默认

.判断结束


游客,如果您要查看本帖隐藏内容请回复

推盘事件

推盘事件

图片资源另类用法

图片资源另类用法
回复

使用道具 举报

精彩评论51

 楼主| 湮灭 发表于 2018-6-7 12:11:38 | 显示全部楼层
抱歉 ,“”托盘事件“”  打成“”推盘事件“”了 ,万分抱歉
回复 支持 反对

使用道具 举报

浮生若梦 发表于 2018-6-7 12:23:37 | 显示全部楼层
嘻嘻不错支持一个
回复 支持 反对

使用道具 举报

2675835142 发表于 2018-6-7 12:35:36 | 显示全部楼层
学习了,这就去试试
回复 支持 反对

使用道具 举报

6360120 发表于 2018-6-7 12:47:34 | 显示全部楼层
不错哦  喜欢 嘿嘿
回复 支持 反对

使用道具 举报

6360120 发表于 2018-6-7 12:59:33 | 显示全部楼层
非常不错,感谢分享!
回复 支持 反对

使用道具 举报

我叫很钢 发表于 2018-6-7 13:11:31 | 显示全部楼层
支持!!!!前排!!!!
回复 支持 反对

使用道具 举报

幻之灭 发表于 2018-6-7 13:12:47 | 显示全部楼层
支持!!!!!!
回复 支持 反对

使用道具 举报

图样图森破丶 发表于 2018-6-7 13:14:03 | 显示全部楼层
很给力。。。。很喜欢
回复 支持 反对

使用道具 举报

找找找 发表于 2018-6-7 13:15:19 | 显示全部楼层
不错不错 支持下
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注我们:觅风论坛与你快乐分享

官方QQ

服务客服QQ:

466-352-670

客服QQ:466352670

Email:466352670@qq.com

Powered by WWW.EYYBA.COM X3.4© 2001-2013 Inc.   版权所有   

觅风论坛  沪ICP备15020893号-1