导读
易语言5.6完美版,可静态编译,绿色无后门

学习易语言 讲究的是系统,如果你正在四处闲逛,你懂的永远是皮毛! 觅风论坛正在为每个困惑的对易语言 详细

[源码] 剪辑板数据处理思路源码【QQNT 复制多图文数据示例】

[复制链接]

微信扫一扫 分享朋友圈

axwxxww 发表于 2024-1-31 10:10:30 | 显示全部楼层 |阅读模式 打印 上一主题 下一主题

马上注册,结交更多易友,享用更多功能,让你轻松玩转觅风论坛。

您需要 登录 才可以下载或查看,没有账号?立即注册

x
想要复制指定格式的数据 如:带格式的html文本 带格式的excel数据 任何聊天程序的复杂数据.... 看着一个教程就够了本来不想发这个帖子的 我记得之前也有很多复制QQ图文数据的源码 但是这里还是重新写一下 我觉得思路真的很简单 但是不知道为什么有人会跟我杠

1.复制原始数据
想办法得到一个你要复制的数据格式,这里既然要做QQNT的聊天所以需要在QQ中发送或者输入一条示例文本然后复制
这里在QQ聊天框输入内容
QQ截图20240131102245.jpg

这时候可以直接复制也可以发送后复制,只要确定复制后粘贴到这里依然可以正常读取即可

2.获取剪辑板原始数据
  1. .版本 2
  2. .支持库 spec

  3. .子程序 getClipboardData
  4. .局部变量 clipboarDataArray, 剪辑版数据, , "0"
  5. .局部变量 i, 整数型

  6. 剪辑板_取所有内容 (clipboarDataArray)  ' 获取你复制的所有内容
  7. .计次循环首 (取数组成员数 (clipboarDataArray), i)
  8.     调试输出 (clipboarDataArray <i>.剪辑版数据格式, clipboarDataArray <i>.字节集长度, clipboarDataArray <i>.文本型数据)
  9. .计次循环尾 ()
复制代码



可以得到以下数据
  1. .版本 2

  2. ' 1: 50305 | 416 | “QQ_Unicode_RichEdit_Format”
  3. ' 2: 49468 | 460 | “HTML Format”
  4. ' 3: 49469 | 4 | “Preferred DropEffect”
  5. ' 4: 15 | 486 | “”
复制代码
此处根据字节集长度来看,明显不是图片数据,如果是图片数据字节集长度不会这么短

那么这时候就用 到文本 / utf8转ansi / unicode转文本 得到明文数据 90%的数据用utf8存取 剩下少部分为 unicode或者明文存取 这里要注意 utf8转ansi 和 到文本 如果在没有中文或者一些外国语言的情况下获取的数据是一样的 尽量复制带中文的数据来获取


再次修改上面的代码改为
  1. .版本 2
  2. .支持库 spec

  3. .子程序 getClipboardData
  4. .局部变量 clipboarDataArray, 剪辑版数据, , "0"
  5. .局部变量 i, 整数型

  6. 剪辑板_取所有内容 (clipboarDataArray)  ' 获取你复制的所有内容
  7. .计次循环首 (取数组成员数 (clipboarDataArray), i)
  8.     调试输出 (clipboarDataArray <i>.剪辑版数据格式, clipboarDataArray <i>.字节集长度, clipboarDataArray <i>.文本型数据)
  9.     调试输出 (编码_Utf8到Ansi (clipboarDataArray <i>.字节集数据))  ' 到文本 utf8转ansi unicode转文本   特别注意 utf8转ansi 和 到文本 如果在没有中文的情况下获取的数据是一样的 99%的程序都是用的utf8编码 这里尽量复制点中文数据试一下
  10. .计次循环尾 ()
复制代码
数据1、2得到两串明文数据 3、4 为乱码数据

因为格式文本复制到这里会无法展示 所以使用图片显示
QQ截图20240131102405.jpg
其实这里也可以看的出来 数据1是QQ专用的复制格式 数据2是html的通用复制格式 是为了兼容添加的 我们只需要修改数据1中的数据复制即可 当然 更推荐修改第二种 一般主流的聊天工具都会兼容html  QQ通用数据可能没有适配的那么好 当然 QQ和WeChat都是支持的 其他数据我们暂时不需要处理 只需要拷贝其中任何一条即可 如果出现问题再来处理其他的数据 一般哪怕你修改内容 也直接按照之前的数据置入即可  直接 调试输出(clipboarDataArray .字节集数据) 得到原始字节集数据 置入进去就好了

3.置剪辑板数据

既然得到格式了 稍作修改再置入即可 这里直接按照格式置入文本数据试一下





游客,如果您要查看本帖隐藏内容请回复
回复

使用道具 举报

精彩评论6

jable 发表于 2024-2-10 15:13:03 | 显示全部楼层
进来学习一下。。。。
回复 支持 反对

使用道具 举报

1150531613 发表于 2024-2-14 13:51:22 | 显示全部楼层
回复查看隐藏内容
回复 支持 反对

使用道具 举报

443651433.. 发表于 2024-2-18 12:29:41 | 显示全部楼层
的法国风格化规范化
回复 支持 反对

使用道具 举报

无敌少爷 发表于 2024-2-22 11:08:00 | 显示全部楼层
这就是传说中的好资源吗?赶紧看看去!
回复 支持 反对

使用道具 举报

sxy19931021 发表于 2024-2-26 09:46:19 | 显示全部楼层
前来支持~~~~~~~~~~~~~~~~~~~
回复 支持 反对

使用道具 举报

张庆伟23 发表于 4 天前 | 显示全部楼层
感觉不错
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注我们:觅风论坛与你快乐分享

收藏本站

用心服务做个非盈利公益编程网站

www.eyyba.com

服务人:觅风论坛

Email:eyyba@foxmail.com

Powered by WWW.EYYBA.COM X3.4© 2001-2023 Inc.   版权所有   

觅风论坛  疆ICP备15020893号-1