导读
易语言5.6完美版,可静态编译,绿色无后门

学习易语言 讲究的是系统,如果你正在四处闲逛,你懂的永远是皮毛! 觅风论坛正在为每个困惑的对易语言 详细

[源码] AES 加解密模块 高端加密易语言加密新源码

[复制链接]

微信扫一扫 分享朋友圈

小一 发表于 2023-10-4 10:23:09 | 显示全部楼层 |阅读模式 打印 上一主题 下一主题

马上注册,结交更多易友,享用更多功能,让你轻松玩转觅风论坛。

您需要 登录 才可以下载或查看,没有账号?立即注册

x
支持的 AES 模式:AES-{128,192,256}-{ECB,CBC,CTR},共 9 种。


不使用系统自带的 wincrypt 接口,移植(编译)自 tiny-AES-c 代码,然后写了些代码把它们黏在一起。


内置了个 DEMO 实例程序来调用里面的接口,可以参考里面的代码来使用。


同时提供了高阶用法的接口,即传入指针进行加解密操作。


易语言 AES 加解密支持模块

版本:



          v2023.1004.01



  说明:



    AES 实现基于 kokke/tiny-AES-c,进行了一些魔改。

    只依赖核心支持库。



    测试于 易语言 5.1,示例程序需要安装有黑月编译环境。

    模块理论上来说应该兼容后续版本的易语言,这个我就不测试了。

    只使用 AES 模块不需要黑月编译环境。

  1. 下面是我在转换十六进制文本和字节集时写的fuzhu函数,性能杠杠的,全是汇编 hhh


  2. .版本 2



  3. .子程序 十六进制到字节集, 字节集, , 原创: 爱飞的猫 @ 52pojie

  4. .参数 文本内容, 文本型, 参考, 非合法字符将会被忽略;[zxsq-anti-bbcode-0x] 会导致解析出错。

  5. .局部变量 长度, 整数型

  6. .局部变量 结果, 字节集



  7. 置入代码 ({ 87, 49, 192, 139, 125, 8, 131, 201, 255, 139, 63, 252, 133, 255, 116, 12, 242, 174, 141, 65, 2, 247, 216, 209, 232, 137, 69, 252, 95 })

  8. .如果真 (长度 ≠ 0)

  9.     结果 = 取空白字节集 (长度)

  10.     置入代码 ({ 139, 77, 8, 139, 9, 139, 85, 248, 131, 194, 8, 232, 27, 0, 0, 0, 229, 144, 190, 231, 136, 177, 231, 160, 180, 232, 167, 163, 32, 45, 32, 231, 136, 177, 233, 163, 158, 231, 154, 132, 231, 140, 171, 88, 49, 192, 138, 1, 132, 192, 116, 56, 60, 65, 124, 12, 60, 97, 125, 20, 60, 70, 127, 41, 44, 55, 235, 18, 60, 48, 124, 33, 60, 57, 127, 29, 44, 48, 235, 6, 60, 102, 127, 21, 44, 87, 53, 0, 0, 255, 255, 120, 9, 8, 224, 136, 2, 66, 49, 192, 235, 3, 193, 224, 12, 65, 235, 194, 139, 69, 248, 141, 72, 8, 41, 202, 137, 80, 4, 201, 194, 4, 0, 232, 168, 255, 255, 255, 124, 150, 0 })

  11. .如果真结束

  12. 返回 (结果)



  13. .子程序 字节集到十六进制, 文本型, , 原创: 爱飞的猫 @ 52pojie

  14. .参数 输入内容, 字节集, 参考

  15. .参数 使用大写, 逻辑型

  16. .参数 添加空格, 逻辑型

  17. .局部变量 长度, 整数型, , , 4

  18. .局部变量 缓冲区, 文本型, , , 8



  19. 置入代码 ({ 139, 69, 8, 139, 0, 139, 64, 4, 49, 210, 131, 125, 16, 0, 15, 69, 208, 141, 4, 66, 137, 69, 252 })

  20. .如果真 (长度 ≠ 0)

  21.     缓冲区 = 取空白文本 (长度)

  22.     置入代码 ({ 86, 87, 83, 139, 125, 248, 139, 117, 8, 139, 54, 139, 78, 4, 131, 198, 8, 184, 87, 0, 0, 0, 186, 55, 0, 0, 0, 131, 125, 12, 0, 15, 68, 208, 133, 201, 116, 50, 138, 6, 192, 232, 4, 179, 48, 60, 10, 15, 77, 218, 1, 216, 136, 7, 71, 138, 6, 36, 15, 179, 48, 60, 10, 15, 77, 218, 1, 216, 136, 7, 71, 70, 198, 7, 32, 141, 71, 1, 131, 125, 16, 0, 15, 69, 248, 73, 235, 202, 43, 125, 16, 198, 7, 0, 91, 95, 94 })

  23. .如果真结束

  24. 返回 (缓冲区)
复制代码
QQ截图20231004103301.jpg




游客,如果您要查看本帖隐藏内容请回复
回复

使用道具 举报

精彩评论45

lloveyouko 发表于 2023-10-6 05:53:31 | 显示全部楼层
感谢感谢分享
回复 支持 反对

使用道具 举报

SMoke 发表于 2023-10-8 01:23:53 | 显示全部楼层
我今天才找到这个论坛,非常高兴,加入到觅风老师的论坛
回复 支持 反对

使用道具 举报

斯蒂芬 发表于 2023-10-9 20:54:15 | 显示全部楼层
看看,到底好不好,想学学看看
回复 支持 反对

使用道具 举报

lloveyouko 发表于 2023-10-11 16:24:38 | 显示全部楼层
不错!顶LZ
回复 支持 反对

使用道具 举报

黑崎一宇啊 发表于 2023-10-13 11:55:00 | 显示全部楼层
感谢您的无私精神...
回复 支持 反对

使用道具 举报

白贝勒 发表于 2023-10-14 02:10:03 | 显示全部楼层
感谢感谢分享
回复 支持 反对

使用道具 举报

白贝勒 发表于 2023-10-14 16:25:06 | 显示全部楼层
还不错觅风论坛欢迎你
回复 支持 反对

使用道具 举报

火狐 发表于 2023-10-15 06:40:09 | 显示全部楼层
看看看看看看看看看看看看
回复 支持 反对

使用道具 举报

小麦555 发表于 2023-10-15 20:55:13 | 显示全部楼层
这就是传说中的好资源吗?赶紧看看去!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注我们:觅风论坛与你快乐分享

收藏本站

用心服务做个非盈利公益编程网站

www.eyyba.com

服务人:觅风论坛

Email:eyyba@foxmail.com

Powered by WWW.EYYBA.COM X3.4© 2001-2023 Inc.   版权所有   

觅风论坛  疆ICP备15020893号-1