易语言实现post登录如何写呢?

2023-9-15 10:13 79 0
简介
登录url:https://xxxx.xxxxx.com/api/user/logindata:{"username":"1111111","password":"222222222222222","type":"mobile"}登录不成功,看了下是http/2,应该怎么写呢?另外协议头里面有 ...
登录url:https://xxxx.xxxxx.com/api/user/login
data:{"username":"1111111","password":"222222222222222","type":"mobile"}
登录不成功,看了下是http/2,应该怎么写呢?另外协议头里面有两个参数
X-AUTH-TOKEN
        iSaMJ99rw3XqKqhOiMx4aNlacO7S0KIP6jzbTwgV30s6zNF4E9gna5glGb9UlTwa
X-AUTH-UUID
        25a83ca9-5e92-4df6-9a82-d32159ce85c5

下面是提供解决办法:
.版本 2
.支持库 spec

.子程序 登录
.参数 手机号, 文本型
.参数 密码, 文本型
.局部变量 局_提交数据, 文本型
.局部变量 局_结果, 字节集
.局部变量 局_返回, 文本型

局_提交数据 = “{” + #引号 + “username” + #引号 + “:” + #引号 + 手机号 + #引号 + “,” + #引号 + “password” + #引号 + “:” + #引号 + 密码 + #引号 + “,” + #引号 + “type” + #引号 + “:” + #引号 + “mobile” + #引号 + “}”
局_结果 = 网页_访问_对象 (“<a href="https://web.baimiaoapp.com/api/user/login" target="_blank">https://web.baimiaoapp.com/api/user/login</a>”, 1, 局_提交数据, , , “content-type: application/json;charset=UTF-8” + #换行符 + “User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36” + #换行符 + “x-auth-uuid: ” + 到小写 (程序_生成GUID ()))
局_返回 = 编码_usc2到ansi (到文本 (局_结果))
调试输出 (局_返回)

鲜花

握手

雷人

路过

鸡蛋

最新文章

关注我们:觅风论坛与你快乐分享

收藏本站

用心服务做个非盈利公益编程网站

www.eyyba.com

服务人:觅风论坛

Email:eyyba@foxmail.com

Powered by WWW.EYYBA.COM X3.4© 2001-2023 Inc.   版权所有   

觅风论坛  疆ICP备15020893号-1